HD SDI 2D layer issue

Please report bugs in this group. We will maybe populate a list of known bugs with a possibly modified description at a later time.

Moderator: Support

Post Reply
User avatar
Robert
Posts: 313
Joined: 21 Jan 2012, 09:25
Location: Toulouse - France
Contact:

HD SDI 2D layer issue

Post by Robert » 28 May 2020, 14:04

Hi devs,

It serms that HD SDI interlaced deltacast input signal is handle in half resolution when we use it within a 2D layer..

Could you check please ?

R

User avatar
Dierk Ohlerich
Posts: 74
Joined: 10 Jul 2012, 09:01
Location: Hamburg, Germany

Re: HD SDI 2D layer issue

Post by Dierk Ohlerich » 28 May 2020, 15:38

The texture of an interlaced input will have half the height (but full width). There is special code that will move the texture up and down by half a pixel to emulate the interlacing, so you get the full resolution over time.

This is tested so that when you have a full-screen layer with an interlaced input, the output will produce exactly the same pixels as the input. Also things will look correctly when duing DVE, for instance mapping the texture on a rotating cube. The fields must never be mixed (and they are not).

If this does not help, which Ventuz version are you using, and has this been a problem before?

-- Dierk
-- Dierk Ohlerich

User avatar
Robert
Posts: 313
Joined: 21 Jan 2012, 09:25
Location: Toulouse - France
Contact:

Re: HD SDI 2D layer issue

Post by Robert » 28 May 2020, 21:43

I don't get you sorry 🤔
What we are trying to do here is to get the interlaced input and have it fullscreen in a progressive output.
So this input should be deinterlaced in order to be used in Ventuz no matter if we gonna use it on a 3d rectangle geometry or fullscreen within a 2d layer.
I think that the method you talked about is related to an interlaced output situation.

Using v6.6.1

R

User avatar
Robert
Posts: 313
Joined: 21 Jan 2012, 09:25
Location: Toulouse - France
Contact:

Re: HD SDI 2D layer issue

Post by Robert » 29 May 2020, 16:42

Hi Dierk,

Any idea ?

R

User avatar
Robert
Posts: 313
Joined: 21 Jan 2012, 09:25
Location: Toulouse - France
Contact:

Re: HD SDI 2D layer issue

Post by Robert » 02 Jun 2020, 15:18

Hi Dierk,

My explaination wasn't miss somme details.
As soon as we add an FX in a 2D Layer + Live Video I noticed this up and down effect in the picture that made the reolution looking divided by two.

See pictures attached. These pictures are rendered in Ventuz and are consecutives.

R
Attachments
Ventuz0071.png
Ventuz0070.png

User avatar
Robert
Posts: 313
Joined: 21 Jan 2012, 09:25
Location: Toulouse - France
Contact:

Re: HD SDI 2D layer issue

Post by Robert » 02 Jun 2020, 18:59

Hi,

As you can see in this gif file (click on the picture to see the gif animation)
Deinterlacing-Bug.gif
The picture of the middle is moving up and down initialy at 50fps.

The gif show 3 situations and I added a zoomed part of the picture on top of each situation:
1. on the left, correct deinterlacing within a 2D Layer Live Video
2. on the middle we added to the 2D Layer Live Video an Effect. The deinterlacing is going up and down. This is the bug.
3. on the right we used a 3D Layer with a live Texture and it is correct.

What I forgot to show is that when we add an Effect node in the 3D Layer the deinterlacing still correct.

Could you have a look please?

Thx

R

Post Reply