Config Editor Crash on Split

Please report bugs in this group. We will maybe populate a list of known bugs with a possibly modified description at a later time.

Moderator: Support

Post Reply
nbdevito
Posts: 4
Joined: 18 Mar 2019, 16:36

Config Editor Crash on Split

Post by nbdevito » 02 May 2019, 21:31

Hoping to get some help tracking down whats wrong.

In the last few updates to Ventuz (I have tested 6.2.0 and 6.3.2), I have been having difficulty creating new Layouts Configurations with the Configuration Editor. I can create a new layout and add new machines with the add dialogue without issues. As soon as I hit split (right-click menu, icon up top, or ctl-shift-s), the configuration editor crashes. I have tried to do this on multiple systems with the same result. My current workaround is to export a layout file from Ventuz 5. Any guidance would be appreciated! Thank you.


Nick

User avatar
Karol
Posts: 568
Joined: 10 Jan 2012, 12:07

Re: Config Editor Crash on Split

Post by Karol » 06 May 2019, 12:57

Hi Nick,

can you please post the exact steps for reproduction of this bug!?

Best Regards
Karol

nbdevito
Posts: 4
Joined: 18 Mar 2019, 16:36

Re: Config Editor Crash on Split

Post by nbdevito » 06 May 2019, 20:02

Sure thing-

Running 6.03.02.163

1. Open Ventuz Configuration Editor
2. Create New Layout with the plus sign icon. Name the layout "Test"
3. Create a Simple 1x1, 1920x1080, 1 Machine output.
4. Left-click output to highlight it.
5. Right-click and click Split.
~Crash~
The application freezes. After sometime a white border appears around the application. If you click it, Windows pops up with the EditConfig is not responding dialogue.

For troubleshooting I have:
- Disabled/uninstalled white label.
- Installed Ventuz on a clean install of Windows 10.
- Removed licenses.
- Completely reinstalled Ventuz after removing Program Files and Public Documents folders.

User avatar
Karol
Posts: 568
Joined: 10 Jan 2012, 12:07

Re: Config Editor Crash on Split

Post by Karol » 13 May 2019, 14:08

Sorry Nick,

I cannot reproduce this.
Are you applying the default split parameters or are you changing anything first?

Best Regards
Karol

User avatar
Karol
Posts: 568
Joined: 10 Jan 2012, 12:07

Re: Config Editor Crash on Split

Post by Karol » 17 May 2019, 09:41

We found out that this is caused by an error in the .Net 4.7 Framework.
To work around you have to reduce your DPI settings below 150%

nbdevito
Posts: 4
Joined: 18 Mar 2019, 16:36

Re: Config Editor Crash on Split

Post by nbdevito » 29 May 2019, 23:09

Awesome. That fixes it. Thank you! Didn't have the issue when systems were set up for production.

Post Reply