Unable to install Deltacast driver

Please report bugs in this group. We will maybe populate a list of known bugs with a possibly modified description at a later time.

Moderator: Support

Post Reply
SamTheSwede
Posts: 90
Joined: 18 Jan 2012, 11:31

Unable to install Deltacast driver

Post by SamTheSwede » 17 Dec 2018, 14:14

Having trouble installing the latest Deltacast driver that came with Ventuz 6.2 - Driver signing issue although Windows is properly updated, any solutions?

The card is a Delta HD Key E 2-2, on Windows 10 in a Dell machine.

// Sam

User avatar
Dierk Ohlerich
Posts: 71
Joined: 10 Jul 2012, 09:01
Location: Hamburg, Germany

Re: Unable to install Deltacast driver

Post by Dierk Ohlerich » 18 Dec 2018, 10:33

Hi,

I just uninstalled and deleted the driver on my machine and installed it anew. And it worked fine.

Are you using the drivers provided by Ventuz? We have a special build, that contains a few bugfixes compared to the official Deltacast SDK 6.08.02.

The hd-key-e 22 driver shows as 2018-10-19 / 6.8.2.0, my Windows shows as Windows 10 Pro / 1803 / 17134.471

-- Dierk
-- Dierk Ohlerich

SamTheSwede
Posts: 90
Joined: 18 Jan 2012, 11:31

Re: Unable to install Deltacast driver

Post by SamTheSwede » 18 Dec 2018, 20:28

Hi Dierk, the drivers are the ones provided by Ventuz. The problem seems to have something to do with the machine they are installed in, I've successfully installed and used the drivers on two other machines, but no luck with this Dell Poweredge server (can't give you the model number now). Decided to try a Decklink Duo card instead which has solved the problem for now. Need to dive deeper into this after the holidays, but for now we're fine.

Thanks!

// Sam

User avatar
Dierk Ohlerich
Posts: 71
Joined: 10 Jul 2012, 09:01
Location: Hamburg, Germany

Re: Unable to install Deltacast driver

Post by Dierk Ohlerich » 19 Dec 2018, 10:02

Ideas:

(A) try to uninstall all deltacast drivers using the "View -> Show hidden Devices" and "Action -> Scan for new devices" menus in the device manager until no more deltacast drivers are shown. Then try to install the driver.

The idea here is may be a newer driver is installed that prevents the older one from installing.

(B) Is the board sitting in a PCIe X4 slot (as it should)? Should work with X1 slot (slowly), but may be new drivers are more picky.

(C) Send the hardware spec and OS version / patch history to Deltacast and have them solve it :-)

(D) Happy holidays

-- DIerk
-- Dierk Ohlerich

Post Reply