Enable/Disable Artnet sACN

A protected forum section for the people testing the upcoming Particle System and all other Features

Moderator: Support

Post Reply
chriss0212
Posts: 665
Joined: 18 Jan 2012, 20:56
Location: wuppertal
Contact:

Enable/Disable Artnet sACN

Post by chriss0212 » 18 Oct 2017, 15:14

It would be nice, if we could enable/ disable send and recieve of ArtNET and sACN seperated by send/ recieve.

If we want to control Ventuz, Ventuz is also starting the server and is blocking the port. That way we can't start Ventuz AND the lighting desk software on the same PC what would be very handy for testing!

Greetings

Christian

User avatar
Tammo
Posts: 5
Joined: 24 Aug 2016, 09:31
Location: Hamburg

Re: Enable/Disable Artnet sACN

Post by Tammo » 18 Oct 2017, 15:53

Hey,

Send/receive is done via the same port, and it needs to be that way because Art-Net (starting from version 3) as well as sACN in multicast mode need some handshaking to support anything beyond basic DMX transmission. So separating send and receive wouldn't really help.

Apart from that - even if you would turn off sending, the explicit port numbers are mostly needed for _receiving_ DMX, so I don't see how disabling the send direction would help at all if you want to control Ventuz from a lighting desk.

That said, when Art-Net is used in Broadcast and sACN is used in multicast mode, the sockets are opened with the REUSEADDR flag; if whatever other software on the same computer plays along it should work.

Tammo

chriss0212
Posts: 665
Joined: 18 Jan 2012, 20:56
Location: wuppertal
Contact:

Re: Enable/Disable Artnet sACN

Post by chriss0212 » 18 Oct 2017, 15:59

Hi Tammo

i will check that ;)

We tried using OnPC and Ventuz on the same machine and it wasn't working. Maybe wrong settings on our site ;)

We already have an ArtNET Script because we are using ArtNET already a long time. This is working in combination with OnPC on the same PC

Greetings

Christian

Post Reply