Full screen problem!

Please report bugs in this group. We will maybe populate a list of known bugs with a possibly modified description at a later time.

Moderator: Support

User avatar
Agalar Ragimov
Posts: 32
Joined: 02 May 2017, 11:29
Location: UAE - Dubai

Full screen problem!

Post by Agalar Ragimov » 05 Oct 2017, 07:30

Hi Everybody,

I am struggling with Ventuz Designer in full screen mode on the 21:9 monitor.

I am working on three monitors.
First is a touchscreen monitor has a screen with 16x9 aspect ratio. It should be "Main" screen.
Second monitor has a screen with 21:9 aspect ratio.
Third monitor has a scree with 16:9 aspect ratio.
All of them connected to one computer.

When I am trying to maximize (make fullscreen) the Ventuz Designer window, it makes invisible the 1/3 of the workspace from right (please check attached printscreen picture). That problem disappears when I am making the second monitor 21:9 "Main" screen but than touch screen on my first monitor doesn't work well.

Is it bug or I can fix it somehow?
Attachments
PrntScreen.png
*_* - You gotta do what you gotta do (even if you don't like it)

joysprod
Posts: 190
Joined: 20 Jan 2012, 12:24
Location: United Kingdom

Re: Full screen problem!

Post by joysprod » 06 Oct 2017, 12:14

Hi,
Although you mention they are connected to one computer, you don't mention if they are in 'Span mode'. Ventuz can only render to one 'screen output'. You therefore have to change your screen output in Windows to Span Mode. Depending on your graphics card it will be called different things.

You would then see something like 5760x1200 as a single monitor.

Hope that helps.

Peter

User avatar
Agalar Ragimov
Posts: 32
Joined: 02 May 2017, 11:29
Location: UAE - Dubai

Re: Full screen problem!

Post by Agalar Ragimov » 08 Oct 2017, 09:00

Hi Peter,

Unfortunately, I can't make "Span Mode" and a wide single monitor [6400x1080] instead of three separate because one of monitors has touch screen. If I make "Span Mode" my touch screen will work wrongly.

Thanks,
Agalar
*_* - You gotta do what you gotta do (even if you don't like it)

joysprod
Posts: 190
Joined: 20 Jan 2012, 12:24
Location: United Kingdom

Re: Full screen problem!

Post by joysprod » 08 Oct 2017, 18:05

Ok, so you can get the correct output when in Span, but the mapping of the touches is incorrect? Ventuz assumed the touch is the entire pixel space. I had the same problem and found I was able to fix this using this touch driver. http://touch-base.com

I had three 1920x1080 screens set up as a 5760x1080 Span. My last monitor was a touch screen, so it's a similar problem to yours. The software allowed me to re-map the touches. You can download a test version before committing to a purchase. Let me know if it works for you.

Peter

User avatar
lerou
Posts: 283
Joined: 06 Sep 2013, 07:14
Location: Hamburg, Germany

Re: Full screen problem!

Post by lerou » 08 Oct 2017, 21:26

Using span mode is a workaround for this problem. However if you want/need to go that way: since 5.3 you can configure the touch mapping in the Ventuz config tool. So you don’t need 3rd party software for the remapping.

cheers,
rou

User avatar
Agalar Ragimov
Posts: 32
Joined: 02 May 2017, 11:29
Location: UAE - Dubai

Re: Full screen problem!

Post by Agalar Ragimov » 30 Jan 2018, 12:41

Hi everybody!
Hope that video will clarify the problem.

https://youtu.be/jWYo3aNN8pI

"Dell" screen on the left is touch screen and it should be "Main Display" from Display Settings because touch doesn't work correctly if it is not "Main Display"
In Ventuz Designer "maximize" button work's well if I make wide "LG" display as a "Main Display" and restart the Ventuz (on the video I didn't restart Ventuz that's why it shows same result when I made middle screen as a "Main Display")

Kind regards,
Agi
*_* - You gotta do what you gotta do (even if you don't like it)

User avatar
Karol
Posts: 503
Joined: 10 Jan 2012, 12:07

Re: Full screen problem!

Post by Karol » 28 Feb 2018, 12:39

Hi,

this will be fixed for Ventuz 5.4 and higher.

Btw, I also have a Dell Touch screen which is not Main Display and do not encounter any problems with touch yet.

Best 'Regards
Karol

User avatar
lerou
Posts: 283
Joined: 06 Sep 2013, 07:14
Location: Hamburg, Germany

Re: Full screen problem!

Post by lerou » 28 Feb 2018, 13:55

Seems not to be a general problem. I have a Dell U2715H@2560x1440 as main, a DELL S2240T@1920x1080 Touch on the left and a Dell U2412M@1200x1920 (portrait mode) on the right and I encounter no issues with fullscreen or maximizing.

User avatar
Agalar Ragimov
Posts: 32
Joined: 02 May 2017, 11:29
Location: UAE - Dubai

Re: Full screen problem!

Post by Agalar Ragimov » 18 Mar 2018, 06:50

Karol wrote:Hi,

this will be fixed for Ventuz 5.4 and higher.
Image
Thank you very much! I am using version 5.4 right now and ohhh so cool to use it full-screen!
Karol wrote:Btw, I also have a Dell Touch screen which is not Main Display and do not encounter any problems with touch yet.

Best 'Regards
Karol
:?
In my case, if I am using another screen as Main, touch sensors from the Dell touch screen works on that screen. For example, if my main screen is Wide LG screen and I am touching my Dell screen on the left top corner it is showing touch on the left top corner of the Wide LG screen. I have no idea why it is happening. Everybody who had same setup as mine in our company faced same touch and full-screen issues
*_* - You gotta do what you gotta do (even if you don't like it)

User avatar
Agalar Ragimov
Posts: 32
Joined: 02 May 2017, 11:29
Location: UAE - Dubai

Re: Full screen problem!

Post by Agalar Ragimov » 18 Mar 2018, 06:55

lerou wrote:Seems not to be a general problem. I have a Dell U2715H@2560x1440 as main, a DELL S2240T@1920x1080 Touch on the left and a Dell U2412M@1200x1920 (portrait mode) on the right and I encounter no issues with fullscreen or maximizing.
:|
Yes, you might be right. Maybe we made something wrong and it just one checkbox in Dell touch screen properties that should be changed from factory settings.
*_* - You gotta do what you gotta do (even if you don't like it)

Post Reply