Preload Movies in Background without affecting playing movie

Q and A about functionality and how to solve a special task for your application.

Moderator: Support

Post Reply
User avatar
Eric_RD
Posts: 101
Joined: 04 Jun 2014, 14:01
Contact:

Preload Movies in Background without affecting playing movie

Post by Eric_RD » 03 Jul 2018, 15:28

I have a "best practise" question

I am controlling a cluster of 4 machines via remoting.
Only use of the cluster is to play out 4k dds videos frame synced on one large Video Wall.
I have a hierarchy of 3 Levels each containing 6 Files (6x6x6Files= 216 Files)
When the first hierarchy level is selected (played) i start preloading the 6 Files of the next Level below.
This way i can start them immediately after I get the trigger.

My problem is that the loading of the 6 Videos in the Background sometimes affects the playing Video (buffer runs empty).
The already playing video then waits for all other movie nodes to fill their buffers before resuming.
I played around with async and disable threading but didn't get a satisfying result.

My option for now is "async" and "disable threading" both enabled and the movie nodes wait for each other and trigger the next one so only one movie is loading at a time (completed -> buffer pass movie File of the next node).
It works but I am not quite happy with it...
Is there a smooth way handling preloading of videos (like prioritizing already running videos)?

Any ideas?

User avatar
Eric_RD
Posts: 101
Joined: 04 Jun 2014, 14:01
Contact:

Re: Preload Movies in Background without affecting playing movie

Post by Eric_RD » 03 Jul 2018, 15:56

Eric_RD wrote:
03 Jul 2018, 15:28
...
Only use of the cluster is to play out 4k dds videos frame synced on one large Video Wall.
...
.hap files not .dds sequences

User avatar
Karol
Posts: 562
Joined: 10 Jan 2012, 12:07

Re: Preload Movies in Background without affecting playing movie

Post by Karol » 27 Jul 2018, 11:19

Hi Eric,

I know it's a little bit late but with V5.4.2 we fixed a resource management problem with the movie resources that pretty sure was causing your issues.
(Bug #10378)

Cheers
Karol

Post Reply