Problem with Text Textures.

Please report bugs in this group. We will maybe populate a list of known bugs with a possibly modified description at a later time.

Moderator: Support

diezweiundvierzig

Re: Problem with Text Textures.

Post by diezweiundvierzig » 28 Apr 2014, 14:28

the broken elements you can see on the second pic. thasts not arabic or hebrew - should be german!

the hardware is an Asus Transformer Book with Win8

User avatar
Karol
Posts: 605
Joined: 10 Jan 2012, 12:07

Re: Problem with Text Textures.

Post by Karol » 29 Apr 2014, 09:23

Did you test it with other machines?
And could you post a real screenshot of the broken fonts elements? The photos are not very helpful.

Cheers
Karol

diezweiundvierzig

Re: Problem with Text Textures.

Post by diezweiundvierzig » 30 Apr 2014, 12:53

Hi Karol,

may I send you an ProjectArchive of the Scene? On other Machines there is everything fine as I said. Even on that machine using Ventuz3!

See attached a screenshot.Image

User avatar
Daniel Willer
Posts: 309
Joined: 06 Jan 2012, 18:12

Re: Problem with Text Textures.

Post by Daniel Willer » 30 Apr 2014, 15:28

Yes please send a ProjectArchive including the Font to
dw@ventuz.com

Cheers
Daniel

User avatar
Karol
Posts: 605
Joined: 10 Jan 2012, 12:07

Re: Problem with Text Textures.

Post by Karol » 05 May 2014, 09:41

Hi,

I tested your scene and cannot reproduce this here.
Your problem might be related to your hardware.
The Asus Transformer Book T100 has only 2GB of memory and a Intel HD Graphics 'board'.

You could try one last thing:
- clear all Ventuz Font caches (Ventuz 3 and 4)
- start Ventuz 3 with the scene (new font resources are created in stored in the cache)
- copy the new Font folder to Ventuz 4 Font cache (C:\ProgramData\Ventuz4\Fonts)
- start Ventuz 4 with the scene

Is the Text still broken?

Cheers
Karol

User avatar
Karol
Posts: 605
Joined: 10 Jan 2012, 12:07

Re: Problem with Text Textures.

Post by Karol » 05 May 2014, 10:28

Oh!
We can reproduce it on one of our laptops.
Stay tuned...

diezweiundvierzig

Re: Problem with Text Textures.

Post by diezweiundvierzig » 07 May 2014, 08:36

Karol wrote: (...)
Your problem might be related to your hardware.
The Asus Transformer Book T100 has only 2GB of memory and a Intel HD Graphics 'board'.
I thought so, too. just wondering, why this occurs only in V4 and not V3!

Karol wrote: (...)
You could try one last thing:
Is the Text still broken?
(...)
still broken :(

User avatar
Karol
Posts: 605
Joined: 10 Jan 2012, 12:07

Re: Problem with Text Textures.

Post by Karol » 08 May 2014, 09:20

Found!
Will be fixed for Ventuz 4.4.0 - scheduled for beginning of June.
The mipmaps which are created on Intel HD Graphics computer are incorrect for texture fonts.
What you could do to work around this, is to create the necessary fonts on a different computer with AMD or Nvidia graphics board and copy the folder on your Intel HD machine.
But make sure that the Character Set settings in the Machine Configuration are the same on both computers!

Best Regards
Karol

Post Reply