Fonts - always fonts...

Please report bugs in this group. We will maybe populate a list of known bugs with a possibly modified description at a later time.

Moderator: Support

Post Reply
SamTheSwede
Posts: 91
Joined: 18 Jan 2012, 11:31

Fonts - always fonts...

Post by SamTheSwede » 25 Mar 2014, 14:49

I have a scene where I use .otf fonts imported into the project on my Win8.1 machine running V4.03.01.752 - Works flawlessly.

Moved the Project to a runtime machine running Win7 and V4.03.02 and the fonts simply doesn't render.... downgrading to same version does not help.

I opened the fonts in HiLogic Font Creator and saved them as .ttf put them into my Project and swithched them out. Works fine, but same issue when using them on the runtime machine....

Why is it Always fonts that's giving me headache?

Tips, solutions, workarounds welcome!!

// Sam

User avatar
Karol
Posts: 605
Joined: 10 Jan 2012, 12:07

Re: Fonts - always fonts...

Post by Karol » 26 Mar 2014, 11:42

Hi Sam!

Do I understand correctly?
- OTF and TTF version of the Font works fine on your Designer machine (Win 8.1)
- Neither of the fonts works on the Runtime machine (Win 7)

Is this a normal windows font or a custom font build only for you?
Did you look into the logs of the Runtime machine?


Best Regards
Karol

SamTheSwede
Posts: 91
Joined: 18 Jan 2012, 11:31

Re: Fonts - always fonts...

Post by SamTheSwede » 26 Mar 2014, 14:24

Hi Karol!

You are correct!

I ended up making a new scene with nothing but two 2DText nodes, one with the otf version and one with the ttf version. This time I did not use the font presets (text, headline, code etc) and in that scene the .ttf version rendered on the Win7 machine, but the otf version did not render.

After going through the scene switching out all the preset fonts and actually picking a .ttf version for every text node, the scene now works.

And then the fun begins.... -the ttf version I had didn't contain any kerning tables, making all text look like crap....
After upgrading to the latest version of HiLogic FontCreator, I was able to convert the otf version to a ttf keeping the kerning table and all is good.

To sum it all up, it seems there is something about the font presets that doesn't change all references or something when replacing a preset font.

The OTF vs TTF is probably a win7 / win8 thing, right?

All the best,

Sam

Post Reply