Syncronization 5.1 Audio and Movie

Q and A about functionality and how to solve a special task for your application.

Syncronization 5.1 Audio and Movie

Postby Lisseni » 21 Mar 2017, 17:16

Hi All

There is task to play video with 5.1 sound. So we have movie and 3 audio files for each audio channel. But Audio plays faster then video. Start is simultaneous but after 10-15 secunds there is big time difference beetween video and audio.
I tryed to run this project on some PCs. And it works perfect at one (motherboard Asus PSQL-E and NVIDIA GeForce GTX 690), but on clients one it fails (Supermicro X10SRA-F and AMD FirePro w9100).
Do you have idea how to sync audio and video?
Image

Best regards
Alisa

uni3dlabs.ru
Lisseni
 
Posts: 1
Joined: 21 Mar 2017, 16:14

Re: Syncronization 5.1 Audio and Movie

Postby ejgazz » 09 May 2017, 14:34

Hi Alisa, I have recently done two projects with 5.1 audio with mixed success, but a few recommendations I can share:

Make sure you use the "audio clip" node instead of the "sounds" node

Also this is copied from the user manual:

"Audio playback nodes get their timing from the sound card. By binding the control of the audio playback node to an animation, the animation takes over the timing, and now the audio playback gets their timing from the video subsystem. Also, movie clip nodes tie the audio timing to video. Now audio and video can drift apart, and this is where audio compensation comes into play.
If audio compensation is enabled, Ventuz will try to speed up or slow down audio playback just slightly to compensate the drift between sound and video subsystem. If it is disabled, audio will skip to the right position when the difference gets too big. This can be controlled by pressing the configure button in the property sheet."

That option can be found by hitting the "configure" option on the node properties.
Eric Gazzillo
Display Designer
Quince Imaging
ejgazz
 
Posts: 7
Joined: 15 Mar 2017, 14:48
Location: Washington, D.C.


Return to How to