Template cued bug

Post requests for new Director features or report bugs to this forum group. Any suggestion to expand the possibilities of Ventuz Director are welcome.

Template cued bug

Postby Robert » 01 Oct 2014, 15:58

Hi,

I saw a bug after I cleared a template:

1. Take a template (A)
2. Cue a new one (B)
3. Clear this new one (B)
4. Take out the first template (A)
-> the cleared template (B) is now cued ??

Rob
User avatar
Robert
 
Posts: 262
Joined: 21 Jan 2012, 09:25
Location: Toulouse - France

Re: Template cued bug

Postby Alex Klein » 01 Oct 2014, 17:15

Thanks for the report. Wow, no idea how that one slipped past me :) I'll try to fix it tomorrow and add another automated test to make sure it never happens again. Should be part of V4.05.01 that's coming soon....
Alex Klein
 

Re: Template cued bug

Postby Alex Klein » 02 Oct 2014, 11:53

Found it, it was caused by a missing update of the internal channel data structures when the template is removed from the property editor. Fixed for V4.05.01.
Alex Klein
 

Re: Template cued bug

Postby Alex Klein » 02 Oct 2014, 12:04

By the way, also found the crash that you send via error report. There is a bug in V4.04 and upwards where the topology crashes when a Ventuz runtime has more pipes configured than what is specified in the topology (for example if the local machine in the topology has been changed to single pipe but the actual Ventuz configuration of the runtime says dual pipe).
Alex Klein
 


Return to Bug Reports & Feature Requests