Forward compatibility....

Post requests for new features to this forum group. Any suggestion to expand the possibilities of Ventuz are welcome.

Forward compatibility....

Postby SamTheSwede » 30 Sep 2015, 10:33

For V5 a great feature would be if the presenter could have some sort of proofing of scenes, so that even if a scene is created in a higher version of Ventuz it would be able to play from presenter if no new nodes or features from the higher version is used within the scene.

Perhaps a new scene compatibility tool could be added that validates a scene and tell the user what versions the scene can be run on?

Today, making a small change in a scene that's been running 24/7 for months is a pain since you either have to downgrade your designer machine, or upgrade the presenter machine. I don't know about you, but I'm all for "Don't fix it if it ain't broken" and upgrading a production machine that has been working flawlessly really falls into that category.

I know, this is a huge thing for dev, but please consider it and keep us multi installation users in mind whenever adding a feature that calls for non forward compatibility!

All the best,

Sam
SamTheSwede
 
Posts: 74
Joined: 18 Jan 2012, 11:31

Return to Feature Requests