Getting rid of video lag

Q and A about functionality and how to solve a special task for your application.

Getting rid of video lag

Postby Samotar26 » 18 Jan 2017, 14:19

Hello everybody,

im currently trying to figure out, how to get rid of video lag while searching in directory during a concert or conference for a background. I have this case:

I got two rectangles on which i set movie clip node on each of them. Only one is always displaying while the other one is for preparing for the next song and im changing those two between songs.
Each of those movie clip nodes is set to a directory node to search in. But while i click next button on keyboard to search through the directory to find a suitable video for next song (this rectangle is not visible on mainscreen), then the movie currently visible on screen lags for few frames. For now its lagging for like 5 frames each time i click the next button and in small cases its for even like a second or so.

It would look terribly if i went to show and everytime i clicked next button on directory node and it would lag.

Already tried this on 3 computers, one better then the other and i always got the same result.
Also tried turning off autoplay, didnt change anything.
Also tried some other stuff like putting videos inside ventuz project directory, same result.
Tried working with excel workbook to input direct directory through it, didnt work either.

Nothing else comes to my mind now so im turning to you for help.

If possible i would like to get rid of it all, or at least get the smallest lag possible.

Thank you for your time, really appreciate it.

With best regards,

Frankie
Samotar26
 
Posts: 11
Joined: 16 Sep 2016, 14:34

Re: Getting rid of video lag

Postby Dennis » 18 Jan 2017, 16:00

Hello Frankie,

please check that your MovieClip node has the "Async" Flag enabled. This may reduce the lag in first.

Since you are working with the "Directory Node" you would have to enable Async directory browsing there as well, BUT the issue is:
Ventuz4 is already Feature complete and does NOT offer this flag.

The workaround in this case is to have you own c# script coded, a directory browser, which works asynchronous.

Another way would be to upgrade to Ventuz5. Ventuz5 has this flag for the Directory node and offers MANY more IPP Effects which could be very handy for your show as well!

Sorry and
Best regArts

Dee

:ugeek:
User avatar
Dennis
 
Posts: 134
Joined: 08 Jun 2015, 11:29

Re: Getting rid of video lag

Postby Samotar26 » 18 Jan 2017, 17:00

Hello Dee,

I will look into it, thank you for your time :)

Frankie
Samotar26
 
Posts: 11
Joined: 16 Sep 2016, 14:34

Re: Getting rid of video lag

Postby Samotar26 » 18 Jan 2017, 17:26

Hello again Dee,

just wanted to thank again, because enabling Async in MovieClip node has solved the problem, thank you again, helped me a lot.

Best regards,

Frankie
Samotar26
 
Posts: 11
Joined: 16 Sep 2016, 14:34


Return to How to...

cron