Movie Clip Advanced crashed playing .mov video

Please report bugs in this group. We will maybe populate a list of known bugs with a possibly modified description at a later time.

Movie Clip Advanced crashed playing .mov video

Postby touleong » 06 May 2013, 11:18

My project is to play a full HD movie (.mov container, H.264 encode, 1920x1080, 48K audio) which is triggered by incoming osc command.
And it will switch to a jpg image after the movie finished playing (completed event fires), the scene is attached for your reference.

The movie clip advanced node is used and the presenter crashed when the movie had been played for around 20 times.
We have tested different quicktime videos, those with audio will crash the presenter after looping for over 20 times, those without audio worked fine without crashing.

the presenter version is 3.08.01
Attachments
show2.vza
(26.01 KiB) Downloaded 248 times
touleong
 
Posts: 3
Joined: 06 May 2013, 10:43
Location: Hong Kong

Re: Movie Clip Advanced crashed playing .mov video

Postby Christian Krix Schmidt » 06 May 2013, 21:50

I recommend you do not use the Quicktime MOV container. It always gave me problems. The best experiences I had so far are a MP$ container with h264 and AAC encoding. From Media Encoder and/or After Effects choose the h264 Format. That will create a MP4 container. I think the Quicktime overhead makes the problems.
Christian Krix Schmidt
 
Posts: 258
Joined: 18 Jan 2012, 11:36
Location: Dubai, United Arab Emirates

Re: Movie Clip Advanced crashed playing .mov video

Postby touleong » 07 May 2013, 03:55

I have tried another mp4(h.264, aac 48k) video, it still crashed after looping for around 2 hours(the length of the video is 3 minutes).
I have also tried the quicktime node to play the .mov video, it has no crash problem after running for over 10 hours, but the performance sucks, the audio always lagging.

Since this is also part of my ventuz cluster, I need to use .mov video because it seems .mov is better at synchronization.
If ventuz donesn't work on this kind of simple project, I am going to lose my confidence....

Any official suggestion on this scenario: "presenter crashed while continuously looping a quicktime video" ?
touleong
 
Posts: 3
Joined: 06 May 2013, 10:43
Location: Hong Kong

Re: Movie Clip Advanced crashed playing .mov video

Postby touleong » 07 May 2013, 05:06

I have tested another video in MP4 container, h.264, aac 48k audio, it still crashed after looping for around 2 hours. the length of the video is about 4 minutes.
Also tried the .mov video using quicktime node, it has no crash problem after running for over 10 hours, but the performance sucks. the audio always lagging.

Can't imagine Ventuz 3 is so unstable on video playback, I am going to lose my confidence.... and patience

Actually this is part of my ventuz cluster, the problem may be worse while I have to sync 4 machines in the cluster.

Is there any official recommendation on video format that Ventuz can just play smoothly and continuously without problem???
touleong
 
Posts: 3
Joined: 06 May 2013, 10:43
Location: Hong Kong

Re: Movie Clip Advanced crashed playing .mov video

Postby Christian Krix Schmidt » 07 May 2013, 09:01

Hmm. Can't help you with that then. I usually only have to deal with synchronization issues in cluster environments and not general playback issues. Have you tried not using the automatic loop feature but instead do your own loop mechanic? Maybe the loop feature has a problem with your files. I would try using the Completed event from the Advanced Movie Clip node and bind that via another Event node to the Seek method of the movie clip. Add a second event node and bind it to the seeked event of the movie clip node and bind that one to the play method. Make sure the AfterSeek property is set to pause so you have to trigger the playback of the movie and of course deactivate the loop property. This is a pretty manual approach. Does this work?

And yes, Quicktime sucks. :)

By the way, I know that Ventuz 4 will have a completely rewritten video playback engine. From what I heard it is exactly what we want and need.
Christian Krix Schmidt
 
Posts: 258
Joined: 18 Jan 2012, 11:36
Location: Dubai, United Arab Emirates


Return to Bug Reports

cron